MTA 1.0.4 Increased outages

Feedback for our SAMP, MTA, TeamSpeak & other servers
Bookmark and Share

MTA 1.0.4 Increased outages

Postby [DRuG]NikT on Mon Jul 05, 2010 2:02 pm

Since the introduction of MTA 1.0.4, a new style of error has been introduced where, if it still has connections open to the internal http server, the error will be reported to MTA's console, instead of the logs, and then just sit there, unlaunched, but not return to shell like it should. As such, each time this happens, I need to manually intervene and relaunch the server.

I've just done so now, but will be raising this with the MTA dev team.

When it occurs, the MTA console says the following:

[12:41:45] ERROR: Could not start HTTP server on interface '(null)' and port '22005'!
[12:41:45] Server stopped!
[12:41:45] Closing SQLite3 database
Press Q to shut down the server!


If you noticed an outage earlier today, it's since been resolved.


"But my head's all messed up, so you better driive brother"
User avatar

[DRuG]NikT
[DRuG] cofounder & your host

Status:
Happy New Year folks!!

[DRuG] cofounder & your host
[DRuG] coleader
[DRuG] member
DRuG server admin
[AGS] member
]DR[ member
 
Posts: 2524
Joined: Sat Jul 28, 2007 10:39 am
Location: Melbourne, Victoria, Australia


Re: MTA 1.0.4 Increased outages

Postby [DRuG]NikT on Thu Jul 29, 2010 7:43 am

UPDATE

OK, I was having a pretty persistent version of the above described problem this morning.

Normally, the "cannot start HTTP" messages come up for a few minutes until all the external connections to it go stale, then the server is able to start. It seems tonight there may be someone persistently trying to load the page... which led me to drill down on the error & actually find a solution.

Google led me to this page on MTA's dev area..

http://bugs.mtasa.com/view.php?id=5392

erla.png

ccw wrote:Linux server
------------
Fixed in release 4 of 1.0.4 Linux server. Available here: http://linux.mtasa.com/ [^]

Windows server
--------------
Currently testing the windows fix. It's the latest file here: http://nightly.mtasa.com/ [^]

Which took me to http://linux.mtasa.com/ where I found & quickly installed, then successfully ran

MTA 1.0.4 - Linux server package.

Release 7 (build 1873) - Updated 25th July 2010

So be careful fellow MTA server admins.. it seems they're updating the builds of both the client (auto) and server (ninja style) without changing the main version number now. [SUSS]

The server does seem to be running better now with the new version.. I've updated the way I name the AGS and DRuG servers to include this new version numbering the mta team seem to have moved to... lets hope they have resolved this issue fully & this error doesn't appear again.


"But my head's all messed up, so you better driive brother"
User avatar

[DRuG]NikT
[DRuG] cofounder & your host

Status:
Happy New Year folks!!

[DRuG] cofounder & your host
[DRuG] coleader
[DRuG] member
DRuG server admin
[AGS] member
]DR[ member
 
Posts: 2524
Joined: Sat Jul 28, 2007 10:39 am
Location: Melbourne, Victoria, Australia



Return to Feedback: DRuG MTA, SAMP, TeamSpeak and other servers

Who is online

Users browsing this forum: No registered users and 1 guest

cron